Aller au contenu
5.3 Moyenne

CVE-2026-82806 Exposure of data element to wrong session vulnerability in Apache APISIX

Description

Exposure of data element to wrong session vulnerability in Apache APISIX. This issue affects Apache APISIX: from 2.3.0 before 3.7.0. Under a supported authz-keycloak configuration, a request's authorization scope could persist into later requests on the same route, leading to unintended authorization expansion and inconsistent access-control decisions. Users are recommended to upgrade to version 3.7.0 or higher, which fixes the issue.

Produits et versions touchés

Produit Versions touchées Corrigé en
Apache APISIX 2.3 2.3.0 → < 3.7.0 3.7.0

Références

Chronologie

  1. Publiée
  2. Dernière modification
Les 34 CVE de Apache APISIX →
Suivre cette CVE