Aller au contenu
5.1 Moyenne

CVE-2026-94276 Improper Authentication vulnerability in Apache APISIX

Description

Improper Authentication vulnerability in Apache APISIX. On a route using openid-connect plugin with remote introspection against an authorization server that serves multiple issuers, a token that introspects as active for one issuer may get accepted on a route restricted to another. This issue affects Apache APISIX: from 3.12.0 through 3.18.0. Users are recommended to upgrade to version 3.19.0, which fixes the issue.

Produits et versions touchés

Produit Versions touchées Corrigé en
Apache APISIX 3.12 3.12.0 → 3.18.0 Pas de correctif indiqué

Références

Chronologie

  1. Publiée
  2. Dernière modification
Les 34 CVE de Apache APISIX →
Suivre cette CVE