6.3
Moyenne
CVE-2026-94269 Use of Non-Canonical URL paths for authorization decisions vulnerability in Apache APISIX
Description
Use of Non-Canonical URL paths for authorization decisions vulnerability in Apache APISIX. In some configurations where a permissive route overlaps a protected one, a crafted encoded path can reach an upstream endpoint that the matched route's policies were never meant to cover. A request that should have been rejected is served instead, giving unauthenticated access to a protected upstream endpoint. This issue affects Apache APISIX: from 2.14.1 through 3.18.0. Users are recommended to upgrade to version 3.19.0, which fixes the issue.
Produits et versions touchés
| Produit | Versions touchées | Corrigé en |
|---|---|---|
| Apache APISIX 2.14 | 2.14.1 → 3.18.0 | Pas de correctif indiqué |
Références
- lists.apache.org lists.apache.org
Chronologie
- Publiée
- Dernière modification
Autres CVE de Apache APISIX
Les 34 CVE de Apache APISIX →
CVE-2026-94276
Improper Authentication vulnerability in Apache APISIX
5.1
Moyenne
CVE-2026-94250
Allocation of resources without limits or throttling vulnerability in batch-requests plugin in Apache APISIX
8.2
Élevée
CVE-2026-94220
Cross-Site request forgery (CSRF) vulnerability in feishu-auth and dingtalk-auth plugins in Apache APISIX
2.1
Faible
CVE-2026-94212
Improper verification of cryptographic signature vulnerability in Apache APISIX
6.4
Moyenne