Skip to content
5.3 Medium

CVE-2026-82806 Exposure of data element to wrong session vulnerability in Apache APISIX

Description

Exposure of data element to wrong session vulnerability in Apache APISIX. This issue affects Apache APISIX: from 2.3.0 before 3.7.0. Under a supported authz-keycloak configuration, a request's authorization scope could persist into later requests on the same route, leading to unintended authorization expansion and inconsistent access-control decisions. Users are recommended to upgrade to version 3.7.0 or higher, which fixes the issue.

Affected products and versions

Product Affected versions Fixed in
Apache APISIX 2.3 2.3.0 → < 3.7.0 3.7.0

References

Timeline

  1. Published
  2. Last modified
The 34 CVEs of Apache APISIX →
Track this CVE