Skip to content
8.2 High

CVE-2026-94250 Allocation of resources without limits or throttling vulnerability in batch-requests plugin in Apache APISIX

Description

Allocation of resources without limits or throttling vulnerability in batch-requests plugin in Apache APISIX. An unauthenticated caller can drive a gateway worker into OOM via a route where the batch-requests plugin is used and the batch endpoint is publicly exposed. This issue affects Apache APISIX: from 1.3.0 through 3.18.0. Users are recommended to upgrade to version 3.19.0, which fixes the issue.

Affected products and versions

Product Affected versions Fixed in
Apache APISIX 1.3 1.3.0 → 3.18.0 No fix stated

References

Timeline

  1. Published
  2. Last modified
The 34 CVEs of Apache APISIX →
Track this CVE