Skip to content
6.4 Medium

CVE-2026-94212 Improper verification of cryptographic signature vulnerability in Apache APISIX

Description

Improper verification of cryptographic signature vulnerability in Apache APISIX. Any unauthenticated attacker could impersonate any user on every route protected by the saml-auth plugin under default configuration. This issue affects Apache APISIX: from 3.17.0 through 3.18.0. Users are recommended to upgrade to version 3.19.0, which fixes the issue.

Affected products and versions

Product Affected versions Fixed in
Apache APISIX 3.17 3.17.0 → 3.18.0 No fix stated

References

Timeline

  1. Published
  2. Last modified
The 34 CVEs of Apache APISIX →
Track this CVE