Aller au contenu
Non notée

CVE-2026-49270 Exposure of Sensitive Information Through Metadata vulnerability in Apache ActiveMQ Broker, Apache ActiveMQ, Apache…

Description

Exposure of Sensitive Information Through Metadata vulnerability in Apache ActiveMQ Broker, Apache ActiveMQ, Apache ActiveMQ All. Brokers that are configured with a network connector with syncDurableSubs set to true, are vulnerable to an unauthenticated attacker who can receive a list of all durable topic subscriptions in the broker, including client identifiers, subscription names, topic destinations, and JMS selector expressions, by sending a BrokerInfo command. The broker incorrectly responds without first ensuring the connection is authenticated. This issue affects Apache ActiveMQ Broker: before 5.19.7, from 6.0.0 before 6.2.6; Apache ActiveMQ: before 5.19.7, from 6.0.0 before 6.2.6; Apache ActiveMQ All: before 5.19.7, from 6.0.0 before 6.2.6. Users are recommended to upgrade to version 6.2.6 or 5.19.7, which fixes the issue.

Produits et versions touchés

Produit Versions touchées Corrigé en
Apache ActiveMQ Broker 6.0 6.0.0 → < 6.2.6 6.2.6
Apache ActiveMQ Broker 5.14 5.14.0 → < 5.19.7 5.19.7
Apache ActiveMQ 6.0 6.0.0 → < 6.2.6 6.2.6
Apache ActiveMQ 5.14 5.14.0 → < 5.19.7 5.19.7
Apache ActiveMQ All 6.0 6.0.0 → < 6.2.6 6.2.6
Apache ActiveMQ All 5.14 5.14.0 → < 5.19.7 5.19.7

Références

Chronologie

  1. Publiée
  2. Dernière modification
Les 15 CVE de Apache ActiveMQ Broker →
Suivre cette CVE