Aller au contenu
Non notée

CVE-2026-61487 Improper Authorization vulnerability in Apache ActiveMQ Broker, Apache ActiveMQ All, Apache ActiveMQ

Description

Improper Authorization vulnerability in Apache ActiveMQ Broker, Apache ActiveMQ All, Apache ActiveMQ. An authenticated low-privilege user can bypass a per-destination write ACL by sending to an ActiveMQ temporary composite destination whose physical name is a comma-separated composite of real queues. This allows publishing messages to any of the destinations in the list without proper write ACL permissions because the authorization check is bypassed due to the composite destination being marked as temporary. This issue affects Apache ActiveMQ Broker: before 5.19.9, from 6.0.0 before 6.2.8; Apache ActiveMQ All: before 5.19.9, from 6.0.0 before 6.2.8; Apache ActiveMQ: before 5.19.9, from 6.0.0 before 6.2.8. Users are recommended to upgrade to version 5.19.9, 6.2.8 or 6.3.0, which fixes the issue.

Produits et versions touchés

Produit Versions touchées Corrigé en
Apache ActiveMQ Broker 6.0 6.0.0 → < 6.2.8 6.2.8
Apache ActiveMQ Broker 5.19 premières → < 5.19.9 5.19.9
Apache ActiveMQ All 6.0 6.0.0 → < 6.2.8 6.2.8
Apache ActiveMQ All 5.19 premières → < 5.19.9 5.19.9
Apache ActiveMQ 6.0 6.0.0 → < 6.2.8 6.2.8
Apache ActiveMQ 5.19 premières → < 5.19.9 5.19.9

Références

Chronologie

  1. Publiée
  2. Dernière modification
Les 15 CVE de Apache ActiveMQ Broker →
Suivre cette CVE