Aller au contenu
Non notée

CVE-2026-49434 Improper Input Validation vulnerability in Apache ActiveMQ Broker, Apache ActiveMQ, Apache ActiveMQ All

Description

Improper Input Validation vulnerability in Apache ActiveMQ Broker, Apache ActiveMQ, Apache ActiveMQ All. An attacker that has access to publish or modify entries in LDAP that match the configured searchBase and searchFilter can instantiate denied transports inside the broker JVM. This can be used to fetch an attacker URL and spawn a second BrokerService inside the same JVM. This issue affects Apache ActiveMQ Broker: before 5.19.8, from 6.0.0 before 6.2.7; Apache ActiveMQ: before 5.19.8, from 6.0.0 before 6.2.7; Apache ActiveMQ All: before 5.19.8, from 6.0.0 before 6.2.7. Users are recommended to upgrade to version 6.2.7 or 5.19.8, which fixes the issue.

Produits et versions touchés

Produit Versions touchées Corrigé en
Apache ActiveMQ Broker 6.0 6.0.0 → < 6.2.7 6.2.7
Apache ActiveMQ Broker 5.19 premières → < 5.19.8 5.19.8
Apache ActiveMQ 6.0 6.0.0 → < 6.2.7 6.2.7
Apache ActiveMQ 5.19 premières → < 5.19.8 5.19.8
Apache ActiveMQ All 6.0 6.0.0 → < 6.2.7 6.2.7
Apache ActiveMQ All 5.19 premières → < 5.19.8 5.19.8

Références

Chronologie

  1. Publiée
  2. Dernière modification
Les 15 CVE de Apache ActiveMQ Broker →
Suivre cette CVE