Aller au contenu
6.8 Moyenne

CVE-2024-35164 The terminal emulator of Apache Guacamole 1.5.5 and older does not properly validate console codes received from servers…

Description

The terminal emulator of Apache Guacamole 1.5.5 and older does not properly validate console codes received from servers via text-based protocols like SSH. If a malicious user has access to a text-based connection, a specially-crafted sequence of console codes could allow arbitrary code to be executed with the privileges of the running guacd process. Users are recommended to upgrade to version 1.6.0, which fixes this issue.

Produits et versions touchés

Produit Versions touchées Corrigé en
Apache Guacamole 0.8 0.8.0 → 1.5.5 Pas de correctif indiqué
Les 8 CVE de Apache Guacamole →
Suivre cette CVE