7.5
Élevée
CVE-2023-43826 Apache Guacamole 1.5.3 and older do not consistently ensure that values received from a VNC server will not result in…
Description
Apache Guacamole 1.5.3 and older do not consistently ensure that values received from a VNC server will not result in integer overflow. If a user connects to a malicious or compromised VNC server, specially-crafted data could result in memory corruption, possibly allowing arbitrary code to be executed with the privileges of the running guacd process. Users are recommended to upgrade to version 1.5.4, which fixes this issue.
Produits et versions touchés
| Produit | Versions touchées | Corrigé en |
|---|---|---|
| Apache Guacamole 1.5 | premières → 1.5.3 | Pas de correctif indiqué |
Autres CVE de Apache Guacamole
Les 8 CVE de Apache Guacamole →
CVE-2024-35164
The terminal emulator of Apache Guacamole 1.5.5 and older does not properly validate console codes received from servers…
6.8
Moyenne
CVE-2023-30576
Apache Guacamole 0.9.10 through 1.5.1 may continue to reference a freed RDP audio input buffer
6.8
Moyenne
CVE-2023-30575
Apache Guacamole 1.5.1 and older may incorrectly calculate the lengths of instruction elements sent during the Guacamole…
6.5
Moyenne
CVE-2021-43999
Apache Guacamole 1.2.0 and 1.3.0 do not properly validate responses received from a SAML identity provider
Non notée