6.8
Medium
CVE-2024-35164 The terminal emulator of Apache Guacamole 1.5.5 and older does not properly validate console codes received from servers…
Description
The terminal emulator of Apache Guacamole 1.5.5 and older does not properly validate console codes received from servers via text-based protocols like SSH. If a malicious user has access to a text-based connection, a specially-crafted sequence of console codes could allow arbitrary code to be executed with the privileges of the running guacd process. Users are recommended to upgrade to version 1.6.0, which fixes this issue.
Affected products and versions
| Product | Affected versions | Fixed in |
|---|---|---|
| Apache Guacamole 0.8 | 0.8.0 → 1.5.5 | No fix stated |
Other CVEs of Apache Guacamole
The 8 CVEs of Apache Guacamole →
CVE-2023-43826
Apache Guacamole 1.5.3 and older do not consistently ensure that values received from a VNC server will not result in…
7.5
High
CVE-2023-30576
Apache Guacamole 0.9.10 through 1.5.1 may continue to reference a freed RDP audio input buffer
6.8
Medium
CVE-2023-30575
Apache Guacamole 1.5.1 and older may incorrectly calculate the lengths of instruction elements sent during the Guacamole…
6.5
Medium
CVE-2021-43999
Apache Guacamole 1.2.0 and 1.3.0 do not properly validate responses received from a SAML identity provider
Not rated