Not rated
CVE-2026-28814 Arbitrary Wiki Markup rendering due to lack of authentication in Apache JSPWiki up to 2.12.3 allows attacker to obtain…
Description
Arbitrary Wiki Markup rendering due to lack of authentication in Apache JSPWiki up to 2.12.3 allows attacker to obtain sensitive data stored in JSPWiki variables. Users are recommended to upgrade to version 2.12.4 or 3.0.0, which fixes this issue.
Affected products and versions
| Product | Affected versions | Fixed in |
|---|---|---|
| Apache JSPWiki 2.12 | earliest → < 2.12.4 | 2.12.4 |
References
- lists.apache.org lists.apache.org
Timeline
- Published
- Last modified
Other CVEs of Apache JSPWiki
The 22 CVEs of Apache JSPWiki →
CVE-2026-48910
A carefully crafted editing request could trigger an XSS vulnerability on Apache JSPWiki when parsing errors on the…
Not rated
CVE-2026-28813
Apache JSPWiki, up to 2.12.3, is vulnerable to JSON Hijacking, which leads to csrf vulnerabilities
Not rated
CVE-2026-28812
UserManager lack of checks allows impersonation in Apache JSPWiki up to 2.12.3 which may allow attackers to escalate…
Not rated
CVE-2026-28811
Debug Messages Revealing Unnecessary Information in Apache JSPWiki up to 2.12.3
Not rated