Skip to content
Not rated

CVE-2026-48910 A carefully crafted editing request could trigger an XSS vulnerability on Apache JSPWiki when parsing errors on the…

Description

A carefully crafted editing request could trigger an XSS vulnerability on Apache JSPWiki when parsing errors on the markdown renderer, which could allow the attacker to execute javascript in the victim's browser and get some sensitive information about the victim. This issue affects Apache JSPWiki: through 2.12.3. Users are recommended to upgrade to version 2.12.4, which fixes the issue.

Affected products and versions

Product Affected versions Fixed in
Apache JSPWiki 2.12 earliest → 2.12.3 No fix stated

References

Timeline

  1. Published
  2. Last modified
The 22 CVEs of Apache JSPWiki →
Track this CVE