Not rated
CVE-2024-47249 Improper Validation of Array Index vulnerability in Apache NimBLE
Description
Improper Validation of Array Index vulnerability in Apache NimBLE. Lack of input validation for HCI events from controller could result in out-of-bound memory corruption and crash. This issue requires broken or bogus Bluetooth controller and thus severity is considered low. This issue affects Apache NimBLE: through 1.7.0. Users are recommended to upgrade to version 1.8.0, which fixes the issue.
Affected products and versions
| Product | Affected versions | Fixed in |
|---|---|---|
| Apache NimBLE 1.7 | earliest → 1.7.0 | No fix stated |
References
- lists.apache.org lists.apache.org
- github.com github.com
Timeline
- Published
- Last modified
Other CVEs of Apache NimBLE
The 11 CVEs of Apache NimBLE →
CVE-2026-46452
Improper Input Validation vulnerability in Apache NimBLE in Mesh Proxy SAR reassembly could result in passing broken…
Not rated
CVE-2026-45816
NULL Pointer Dereference vulnerability in Apache NimBLE in LE Long Term Key Request event
Not rated
CVE-2026-45815
Reachable Assertion vulnerability in Apache NimBLE
Not rated
CVE-2026-45813
Out-of-bounds Write, Integer Underflow (Wrap or Wraparound) vulnerability in Apache NimBLE BASS service
Not rated