Skip to content
Not rated

CVE-2026-45815 Reachable Assertion vulnerability in Apache NimBLE

Description

Reachable Assertion vulnerability in Apache NimBLE. A specially crafted ATT Read Multiple Variable Response (BLE_ATT_OP_READ_MULT_VAR_RSP) may trigger assert in ATT parser. Severity is medium as this requires DUT to first send ATT Read Multiple Variable Request. This issue affects Apache NimBLE: through 1.9.0. Users are recommended to upgrade to version 1.10.0, which fixes the issue.

Affected products and versions

Product Affected versions Fixed in
Apache NimBLE 1.9 earliest → 1.9.0 No fix stated

References

Timeline

  1. Published
  2. Last modified
The 11 CVEs of Apache NimBLE →
Track this CVE