Non notée
CVE-2026-45815 Reachable Assertion vulnerability in Apache NimBLE
Description
Reachable Assertion vulnerability in Apache NimBLE. A specially crafted ATT Read Multiple Variable Response (BLE_ATT_OP_READ_MULT_VAR_RSP) may trigger assert in ATT parser. Severity is medium as this requires DUT to first send ATT Read Multiple Variable Request. This issue affects Apache NimBLE: through 1.9.0. Users are recommended to upgrade to version 1.10.0, which fixes the issue.
Produits et versions touchés
| Produit | Versions touchées | Corrigé en |
|---|---|---|
| Apache NimBLE 1.9 | premières → 1.9.0 | Pas de correctif indiqué |
Références
- github.com github.com
- lists.apache.org lists.apache.org
Chronologie
- Publiée
- Dernière modification
Autres CVE de Apache NimBLE
Les 11 CVE de Apache NimBLE →
CVE-2026-46452
Improper Input Validation vulnerability in Apache NimBLE in Mesh Proxy SAR reassembly could result in passing broken…
Non notée
CVE-2026-45816
NULL Pointer Dereference vulnerability in Apache NimBLE in LE Long Term Key Request event
Non notée
CVE-2026-45813
Out-of-bounds Write, Integer Underflow (Wrap or Wraparound) vulnerability in Apache NimBLE BASS service
Non notée
CVE-2026-45812
Incorrect Calculation of Buffer Size vulnerability in Apache NimBLE when processing Legacy Advertising Report HCI event
Non notée