Skip to content
Not rated

CVE-2024-40761 Inadequate Encryption Strength vulnerability in Apache Answer

Description

Inadequate Encryption Strength vulnerability in Apache Answer. This issue affects Apache Answer: through 1.3.5. Using the MD5 value of a user's email to access Gravatar is insecure and can lead to the leakage of user email. The official recommendation is to use SHA256 instead. Users are recommended to upgrade to version 1.4.0, which fixes the issue.

Affected products and versions

Product Affected versions Fixed in
Apache Answer 1.3 earliest → 1.3.5 No fix stated
answer 1.3 earliest → 1.3.5 No fix stated
The 37 CVEs of Apache Answer →
Track this CVE