Skip to content
Not rated

CVE-2023-50164 An attacker can manipulate file upload params to enable paths traversal and under some circumstances this can lead to…

Description

An attacker can manipulate file upload params to enable paths traversal and under some circumstances this can lead to uploading a malicious file which can be used to perform Remote Code Execution. Users are recommended to upgrade to versions Struts 2.5.33 or Struts 6.3.0.2 or greater to fix this issue.

Affected products and versions

Product Affected versions Fixed in
Apache Struts 6.0 6.0.0 → 6.3.0.1 No fix stated
Apache Struts 2.0 2.0.0 → 2.5.32 No fix stated

References

Timeline

  1. Published
  2. Last modified
The 33 CVEs of Apache Struts →
Track this CVE