Non notée
CVE-2023-50164 An attacker can manipulate file upload params to enable paths traversal and under some circumstances this can lead to…
Description
An attacker can manipulate file upload params to enable paths traversal and under some circumstances this can lead to uploading a malicious file which can be used to perform Remote Code Execution. Users are recommended to upgrade to versions Struts 2.5.33 or Struts 6.3.0.2 or greater to fix this issue.
Produits et versions touchés
| Produit | Versions touchées | Corrigé en |
|---|---|---|
| Apache Struts 6.0 | 6.0.0 → 6.3.0.1 | Pas de correctif indiqué |
| Apache Struts 2.0 | 2.0.0 → 2.5.32 | Pas de correctif indiqué |
Références
- lists.apache.org lists.apache.org
- www.openwall.com www.openwall.com
- packetstormsecurity.com packetstormsecurity.com
- security.netapp.com security.netapp.com
Chronologie
- Publiée
- Dernière modification
Autres CVE de Apache Struts
Les 33 CVE de Apache Struts →
CVE-2026-104714
Concurrent execution using shared resource with improper synchronization ('race condition') vulnerability in Apache…
Non notée
CVE-2026-104713
Allocation of resources without limits or throttling vulnerability in the Apache Struts REST plugin
Non notée
CVE-2026-104712
Asymmetric resource consumption (amplification) vulnerability in Apache Struts
Non notée
CVE-2026-104711
Improper neutralization of special elements used in an expression language statement ('Expression Language Injection')…
Non notée