Not rated
CVE-2026-104711 Improper neutralization of special elements used in an expression language statement ('Expression Language Injection')…
Description
Improper neutralization of special elements used in an expression language statement ('Expression Language Injection') vulnerability in Apache Struts. If the application is configured to use the legacy RESTful action mapper, a crafted request can inject an OGNL expression that may lead to remote code execution. Struts 7 is affected only when the OGNL allowlist is disabled; it is enabled by default. Applications using the default action mapper, the restful2 mapper, or the Struts REST plugin are not affected. This issue affects Apache Struts: from 2.0.0 through 2.3.37, from 2.5.0 through 2.5.33, from 6.0.0 through 6.11.0, from 7.0.0 through 7.3.0. Users are recommended to upgrade to version 6.12.0 or 7.4.0, which fixes the issue.
Affected products and versions
| Product | Affected versions | Fixed in |
|---|---|---|
| Apache Struts 7.0 | 7.0.0 → 7.3.0 | No fix stated |
| Apache Struts 6.0 | 6.0.0 → 6.11.0 | No fix stated |
| Apache Struts 2.5 | 2.5.0 → 2.5.33 | No fix stated |
| Apache Struts 2.0 | 2.0.0 → 2.3.37 | No fix stated |
References
- cwiki.apache.org cwiki.apache.org
Timeline
- Published
- Last modified
Other CVEs of Apache Struts
The 33 CVEs of Apache Struts →
CVE-2026-104714
Concurrent execution using shared resource with improper synchronization ('race condition') vulnerability in Apache…
Not rated
CVE-2026-104713
Allocation of resources without limits or throttling vulnerability in the Apache Struts REST plugin
Not rated
CVE-2026-104712
Asymmetric resource consumption (amplification) vulnerability in Apache Struts
Not rated
CVE-2026-73632
Exposure of data element to wrong session vulnerability in the JSON plugin of Apache Struts
Not rated