Skip to content
Not rated

CVE-2022-39944 In Apache…

Description

In Apache Linkis <=1.2.0 when used with the MySQL Connector/J, a deserialization vulnerability with possible remote code execution impact exists when an attacker has write access to a database and configures a JDBC EC with a MySQL data source and malicious parameters. Therefore, the parameters in the jdbc url should be blacklisted. Versions of Apache Linkis <= 1.2.0 will be affected, We recommend users to update to 1.3.0.

Affected products and versions

Product Affected versions Fixed in
Apache Linkis 1.2 earliest → 1.2.0 No fix stated

References

Timeline

  1. Published
  2. Last modified
The 8 CVEs of Apache Linkis →
Track this CVE