Not rated
CVE-2021-44140 Remote attackers may delete arbitrary files in a system hosting a JSPWiki instance, versions up to 2.11.0.M8, by using a…
Description
Remote attackers may delete arbitrary files in a system hosting a JSPWiki instance, versions up to 2.11.0.M8, by using a carefuly crafted http request on logout, given that those files are reachable to the user running the JSPWiki instance. Apache JSPWiki users should upgrade to 2.11.0 or later.
Affected products and versions
| Product | Affected versions | Fixed in |
|---|---|---|
| Apache JSPWiki 2.11 | earliest → 2.11.0.M8 | No fix stated |
References
- jspwiki-wiki.apache.org jspwiki-wiki.apache.org
- lists.apache.org lists.apache.org
Timeline
- Published
- Last modified
Other CVEs of Apache JSPWiki
The 22 CVEs of Apache JSPWiki →
CVE-2026-48910
A carefully crafted editing request could trigger an XSS vulnerability on Apache JSPWiki when parsing errors on the…
Not rated
CVE-2026-28814
Arbitrary Wiki Markup rendering due to lack of authentication in Apache JSPWiki up to 2.12.3 allows attacker to obtain…
Not rated
CVE-2026-28813
Apache JSPWiki, up to 2.12.3, is vulnerable to JSON Hijacking, which leads to csrf vulnerabilities
Not rated
CVE-2026-28812
UserManager lack of checks allows impersonation in Apache JSPWiki up to 2.12.3 which may allow attackers to escalate…
Not rated