Skip to content
5.4 Medium

CVE-2020-15169 In Action View before versions 5.2.4.4 and 6.0.3.3 there is a potential Cross-Site Scripting (XSS) vulnerability in…

Description

In Action View before versions 5.2.4.4 and 6.0.3.3 there is a potential Cross-Site Scripting (XSS) vulnerability in Action View's translation helpers. Views that allow the user to control the default (not found) value of the `t` and `translate` helpers could be susceptible to XSS attacks. When an HTML-unsafe string is passed as the default for a missing translation key named html or ending in _html, the default string is incorrectly marked as HTML-safe and not escaped. This is patched in versions 6.0.3.3 and 5.2.4.4. A workaround without upgrading is proposed in the source advisory.

Affected products and versions

Product Affected versions Fixed in
actionview 6.0 6.0.0.0 → < 6.0.3.3 6.0.3.3
actionview 5.2 earliest → < 5.2.4.4 5.2.4.4

References

Timeline

  1. Published
  2. Last modified
The 3 CVEs of actionview →
Track this CVE