5.4
Moyenne
CVE-2020-15169 In Action View before versions 5.2.4.4 and 6.0.3.3 there is a potential Cross-Site Scripting (XSS) vulnerability in…
Description
In Action View before versions 5.2.4.4 and 6.0.3.3 there is a potential Cross-Site Scripting (XSS) vulnerability in Action View's translation helpers. Views that allow the user to control the default (not found) value of the `t` and `translate` helpers could be susceptible to XSS attacks. When an HTML-unsafe string is passed as the default for a missing translation key named html or ending in _html, the default string is incorrectly marked as HTML-safe and not escaped. This is patched in versions 6.0.3.3 and 5.2.4.4. A workaround without upgrading is proposed in the source advisory.
Produits et versions touchés
| Produit | Versions touchées | Corrigé en |
|---|---|---|
| actionview 6.0 | 6.0.0.0 → < 6.0.3.3 | 6.0.3.3 |
| actionview 5.2 | premières → < 5.2.4.4 | 5.2.4.4 |
Références
- github.com github.com
- DSA-4766 www.debian.org
- FEDORA-2020-4dd34860a3 lists.fedoraproject.org
- [debian-lts-announce] 20201009 [SECURITY] [DLA 2403-1] rails security update lists.debian.org
Chronologie
- Publiée
- Dernière modification