4.0
Medium
CVE-2020-5267 In ActionView before versions 6.0.2.2 and 5.2.4.2, there is a possible XSS vulnerability in ActionView's JavaScript…
Description
In ActionView before versions 6.0.2.2 and 5.2.4.2, there is a possible XSS vulnerability in ActionView's JavaScript literal escape helpers. Views that use the `j` or `escape_javascript` methods may be susceptible to XSS attacks. The issue is fixed in versions 6.0.2.2 and 5.2.4.2.
Affected products and versions
| Product | Affected versions | Fixed in |
|---|---|---|
| actionview 6.0 | 6.0.0 → < 6.0.2.2 | 6.0.2.2 |
| actionview 5.2 | earliest → < 5.2.4.2 | 5.2.4.2 |
References
- github.com github.com
- github.com github.com
- [oss-security] 20200319 [CVE-2020-5267] Possible XSS vulnerability in ActionView www.openwall.com
- [debian-lts-announce] 20200320 [SECURITY] [DLA 2149-1] rails security update lists.debian.org
- openSUSE-SU-2020:0627 lists.opensuse.org
- FEDORA-2020-4dd34860a3 lists.fedoraproject.org
Timeline
- Published
- Last modified