Skip to content
5.1 Medium

CVE-2026-94276 Improper Authentication vulnerability in Apache APISIX

Description

Improper Authentication vulnerability in Apache APISIX. On a route using openid-connect plugin with remote introspection against an authorization server that serves multiple issuers, a token that introspects as active for one issuer may get accepted on a route restricted to another. This issue affects Apache APISIX: from 3.12.0 through 3.18.0. Users are recommended to upgrade to version 3.19.0, which fixes the issue.

Affected products and versions

Product Affected versions Fixed in
Apache APISIX 3.12 3.12.0 → 3.18.0 No fix stated

References

Timeline

  1. Published
  2. Last modified
The 34 CVEs of Apache APISIX →
Track this CVE