Skip to content
Not rated

CVE-2025-26413 Improper Input Validation vulnerability in Apache Kvrocks

Description

Improper Input Validation vulnerability in Apache Kvrocks. The SETRANGE command didn't check if the `offset` input is a positive integer and use it as an index of a string. So it will cause the server to crash due to its index is  out of range. This issue affects Apache Kvrocks: through 2.11.1. Users are recommended to upgrade to version 2.12.0, which fixes the issue.

Affected products and versions

Product Affected versions Fixed in
Apache Kvrocks 2.11 earliest → 2.11.1 No fix stated

References

Timeline

  1. Published
  2. Last modified
The 9 CVEs of Apache Kvrocks →
Track this CVE