Aller au contenu
Non notée

CVE-2025-26413 Improper Input Validation vulnerability in Apache Kvrocks

Description

Improper Input Validation vulnerability in Apache Kvrocks. The SETRANGE command didn't check if the `offset` input is a positive integer and use it as an index of a string. So it will cause the server to crash due to its index is  out of range. This issue affects Apache Kvrocks: through 2.11.1. Users are recommended to upgrade to version 2.12.0, which fixes the issue.

Produits et versions touchés

Produit Versions touchées Corrigé en
Apache Kvrocks 2.11 premières → 2.11.1 Pas de correctif indiqué

Références

Chronologie

  1. Publiée
  2. Dernière modification
Les 9 CVE de Apache Kvrocks →
Suivre cette CVE