Skip to content
Not rated

CVE-2024-47249 Improper Validation of Array Index vulnerability in Apache NimBLE

Description

Improper Validation of Array Index vulnerability in Apache NimBLE. Lack of input validation for HCI events from controller could result in out-of-bound memory corruption and crash. This issue requires broken or bogus Bluetooth controller and thus severity is considered low. This issue affects Apache NimBLE: through 1.7.0. Users are recommended to upgrade to version 1.8.0, which fixes the issue.

Affected products and versions

Product Affected versions Fixed in
Apache NimBLE 1.7 earliest → 1.7.0 No fix stated

References

Timeline

  1. Published
  2. Last modified
The 11 CVEs of Apache NimBLE →
Track this CVE