Non notée
CVE-2026-48207 Deserialization of untrusted data in Apache Fory PyFory
Description
Deserialization of untrusted data in Apache Fory PyFory. PyFory's ReduceSerializer could bypass documented DeserializationPolicy validation hooks during reduce-state restoration and global-name resolution. An application is vulnerable if it deserializes attacker-controlled data using PyFory Python-native mode with strict mode disabled and relies on DeserializationPolicy to restrict unsafe classes, functions, or module attributes. This issue affects Apache Fory: from before 1.0.0. Mitigation: Users of Apache Fory are recommended to upgrade to version 1.0.0 or later, which enforces DeserializationPolicy validation for the affected ReduceSerializer paths and thus fixes this issue.
Produits et versions touchés
| Produit | Versions touchées | Corrigé en |
|---|---|---|
| Apache Fory 0.13 | 0.13.0 → < 1.0.0 | 1.0.0 |
Références
- fory.apache.org fory.apache.org
Chronologie
- Publiée
- Dernière modification
Autres CVE de Apache Fory
Les 11 CVE de Apache Fory →
CVE-2026-71559
Deserialization of Untrusted Data vulnerability in the Go implementation of Apache Fory allows an attacker to cause a…
Non notée
CVE-2026-71558
Heap type confusion vulnerability in Apache Fory C++ deserialization
Non notée
CVE-2026-71560
Out-of-bounds Read vulnerability in Apache Fory C++ deserialization
Non notée
CVE-2026-60080
Use After Free vulnerability in the Rust deserialization logic of Apache Fory
Non notée