Non notée
CVE-2026-46588 Improper Input Validation vulnerability in Apache Camel
Description
Improper Input Validation vulnerability in Apache Camel. This issue affects Apache Camel: through 4.14.7, from 4.15.0 through 4.18.2, from 4.19.0 through 4.20.0. Users are recommended to upgrade to version 4.14.8, 4.18.3, 4.21.0, which fixes the issue.
Produits et versions touchés
| Produit | Versions touchées | Corrigé en |
|---|---|---|
| Apache Camel 4.19 | 4.19.0 → 4.20.0 | Pas de correctif indiqué |
| Apache Camel 4.15 | 4.15.0 → 4.18.2 | Pas de correctif indiqué |
| Apache Camel 4.14 | premières → 4.14.7 | Pas de correctif indiqué |
Autres CVE de Apache Camel
Les 97 CVE de Apache Camel →
CVE-2026-71569
Server-Side Request Forgery (SSRF) vulnerability in Apache Camel A2A component
4.8
Moyenne
CVE-2026-90885
Improper Restriction of XML External Entity Reference vulnerability in Apache Camel Saxon component
7.5
Élevée
CVE-2026-94386
Use of Cache Containing Sensitive Information vulnerability in Apache Camel Oauth component
4.8
Moyenne
CVE-2026-95628
Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal') vulnerability in Apache Camel Docling…
5.4
Moyenne