Not rated
CVE-2026-46588 Improper Input Validation vulnerability in Apache Camel
Description
Improper Input Validation vulnerability in Apache Camel. This issue affects Apache Camel: through 4.14.7, from 4.15.0 through 4.18.2, from 4.19.0 through 4.20.0. Users are recommended to upgrade to version 4.14.8, 4.18.3, 4.21.0, which fixes the issue.
Affected products and versions
| Product | Affected versions | Fixed in |
|---|---|---|
| Apache Camel 4.19 | 4.19.0 → 4.20.0 | No fix stated |
| Apache Camel 4.15 | 4.15.0 → 4.18.2 | No fix stated |
| Apache Camel 4.14 | earliest → 4.14.7 | No fix stated |
References
- camel.apache.org camel.apache.org
Timeline
- Published
- Last modified
Other CVEs of Apache Camel
The 97 CVEs of Apache Camel →
CVE-2026-71569
Server-Side Request Forgery (SSRF) vulnerability in Apache Camel A2A component
4.8
Medium
CVE-2026-90885
Improper Restriction of XML External Entity Reference vulnerability in Apache Camel Saxon component
7.5
High
CVE-2026-94386
Use of Cache Containing Sensitive Information vulnerability in Apache Camel Oauth component
4.8
Medium
CVE-2026-95628
Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal') vulnerability in Apache Camel Docling…
5.4
Medium