Aller au contenu
Non notée

CVE-2026-42782 Improper Isolation or Compartmentalization vulnerability in Apache Syncope

Description

Improper Isolation or Compartmentalization vulnerability in Apache Syncope. An administrator with adequate entitlements for Implementations can create a malicious Groovy class containing untrusted code reaching a non-sandboxed execution path via the class static initializer. This issue affects Apache Syncope: 3.0 through 3.0.16, 4.0 through 4.0.5, 4.1.0. Users are recommended to upgrade to version 4.0.6 / 4.1.1, which fix this issue by forcing even the static initializer in Groovy code to run in a sandbox.

Produits et versions touchés

Produit Versions touchées Corrigé en
Apache Syncope 4.1 4.1 → 4.1.0 Pas de correctif indiqué
Apache Syncope 4.0 4.0 → 4.0.5 Pas de correctif indiqué
Apache Syncope 3.0 3.0 → 3.0.16 Pas de correctif indiqué

Références

Chronologie

  1. Publiée
  2. Dernière modification
Les 45 CVE de Apache Syncope →
Suivre cette CVE