7.2
Élevée
CVE-2025-6965 Integer Truncation on SQLite
Description
There exists a vulnerability in SQLite versions before 3.50.2 where the number of aggregate terms could exceed the number of columns available. This could lead to a memory corruption issue. We recommend upgrading to version 3.50.2 or above.
Détail CVSS 4.0
Vecteur CVSS:4.0/AV:N/AC:H/AT:P/PR:L/UI:N/VC:L/VI:H/VA:L/SC:L/SI:H/SA:L/S:N/AU:N/R:U/V:D/RE:L/U:GreenExploitable à distance par le réseau, avec un compte ordinaire et sans action d’un utilisateur ; un attaquant peut compromettre gravement la confidentialité, l’intégrité ou la disponibilité.
- Vecteur d’attaque
- Réseau
- Complexité
- Élevée
- Prérequis d’attaque
- Présents
- Privilèges requis
- Faibles
- Interaction
- Aucune
- Confidentialité
- Faible
- Intégrité
- Élevé
- Disponibilité
- Faible
- Confidentialité des autres systèmes
- Faible
- Intégrité des autres systèmes
- Élevé
- Disponibilité des autres systèmes
- Faible
Produits et versions touchés
| Produit | Versions touchées | Corrigé en |
|---|---|---|
| SQLite 3.50 | premières → < 3.50.2 | 3.50.2 |
| RUGGEDCOM CROSSBOW Station Access Controller (SAC) 6.0 | premières → < 6.0 | 6.0 |
| SIDIS Prime 4.0 | premières → < 4.0.800 | 4.0.800 |
Références
- www.sqlite.org www.sqlite.org
Chronologie
- Publiée
- Dernière modification
Autres CVE de SQLite
Les 18 CVE de SQLite →
CVE-2026-119591
SQLite before 3.54.0 Stack Exhaustion via countOfViewOptimization() in VALUES Clause
6.8
Moyenne
CVE-2026-119586
SQLite command-line shell through 3.54.1 contains a command injection vulnerability in the .recover command that emits…
8.5
Élevée
CVE-2026-119379
SQLite before 3.54.0 built with the session extension contains a heap buffer overflow vulnerability in…
8.5
Élevée
CVE-2026-119378
SQLite before 3.54.0 contains a use-after-free vulnerability in the R-Tree extension that allows attackers to make…
6.8
Moyenne