Skip to content
7.2 High

CVE-2025-6965 Integer Truncation on SQLite

Description

There exists a vulnerability in SQLite versions before 3.50.2 where the number of aggregate terms could exceed the number of columns available. This could lead to a memory corruption issue. We recommend upgrading to version 3.50.2 or above.

CVSS 4.0 detail

Vector CVSS:4.0/AV:N/AC:H/AT:P/PR:L/UI:N/VC:L/VI:H/VA:L/SC:L/SI:H/SA:L/S:N/AU:N/R:U/V:D/RE:L/U:Green

Exploitable remotely over the network, with an ordinary account and without any user action; an attacker can seriously compromise confidentiality, integrity or availability.

Attack vector
Network
Attack complexity
High
Attack requirements
Present
Privileges required
Low
Interaction
None
Confidentiality
Low
Integrity
High
Availability
Low
Confidentiality of other systems
Low
Integrity of other systems
High
Availability of other systems
Low

Affected products and versions

Product Affected versions Fixed in
SQLite 3.50 earliest → < 3.50.2 3.50.2
RUGGEDCOM CROSSBOW Station Access Controller (SAC) 6.0 earliest → < 6.0 6.0
SIDIS Prime 4.0 earliest → < 4.0.800 4.0.800

References

Timeline

  1. Published
  2. Last modified
The 18 CVEs of SQLite →
Track this CVE