Aller au contenu
Non notée

CVE-2025-59454 In Apache CloudStack, a gap in access control checks affected the APIs - createNetworkACL - listNetworkACLs -…

Description

In Apache CloudStack, a gap in access control checks affected the APIs - createNetworkACL - listNetworkACLs - listResourceDetails - listVirtualMachinesUsageHistory - listVolumesUsageHistory While these APIs were accessible only to authorized users, insufficient permission validation meant that users could occasionally access information beyond their intended scope. Users are recommended to upgrade to Apache CloudStack 4.20.2.0 or 4.22.0.0, which fixes the issue.

Produits et versions touchés

Produit Versions touchées Corrigé en
Apache CloudStack 4.21 4.21.0 → < 4.22.0 4.22.0
Apache CloudStack 4.0 4.0.0 → < 4.20.2 4.20.2

Références

Chronologie

  1. Publiée
  2. Dernière modification
Les 51 CVE de Apache CloudStack →
Suivre cette CVE