Not rated
CVE-2025-59454 In Apache CloudStack, a gap in access control checks affected the APIs - createNetworkACL - listNetworkACLs -…
Description
In Apache CloudStack, a gap in access control checks affected the APIs - createNetworkACL - listNetworkACLs - listResourceDetails - listVirtualMachinesUsageHistory - listVolumesUsageHistory While these APIs were accessible only to authorized users, insufficient permission validation meant that users could occasionally access information beyond their intended scope. Users are recommended to upgrade to Apache CloudStack 4.20.2.0 or 4.22.0.0, which fixes the issue.
Affected products and versions
| Product | Affected versions | Fixed in |
|---|---|---|
| Apache CloudStack 4.21 | 4.21.0 → < 4.22.0 | 4.22.0 |
| Apache CloudStack 4.0 | 4.0.0 → < 4.20.2 | 4.20.2 |
Other CVEs of Apache CloudStack
The 51 CVEs of Apache CloudStack →
CVE-2026-59654
Missing Release of Resource after Effective Lifetime vulnerability in Apache CloudStack's scoped global configuration…
6.8
Medium
CVE-2026-47359
Improper Neutralization of Special Elements used in an OS Command ('OS Command Injection') vulnerability in Apache…
Not rated
CVE-2026-50112
SSRF via Metalink Mirror URL Resolution: An authenticated tenant can register a template pointing to an…
Not rated
CVE-2026-50222
Missing Authorization, Exposure of Sensitive Information to an Unauthorized Actor vulnerability in Apache CloudStack's…
Not rated