CVE-2024-23321 For RocketMQ versions 5.2.0 and below, under certain conditions, there is a risk of exposure of sensitive Information to…
Description
For RocketMQ versions 5.2.0 and below, under certain conditions, there is a risk of exposure of sensitive Information to an unauthorized actor even if RocketMQ is enabled with authentication and authorization functions. An attacker, possessing regular user privileges or listed in the IP whitelist, could potentially acquire the administrator's account and password through specific interfaces. Such an action would grant them full control over RocketMQ, provided they have access to the broker IP address list. To mitigate these security threats, it is strongly advised that users upgrade to version 5.3.0 or newer. Additionally, we recommend users to use RocketMQ ACL 2.0 instead of the original RocketMQ ACL when upgrading to version Apache RocketMQ 5.3.0.
Produits et versions touchés
| Produit | Versions touchées | Corrigé en |
|---|---|---|
| Apache RocketMQ 4.5 | 4.5.2 → 5.2.0 | Pas de correctif indiqué |
| rocketmq 4.5 | 4.5.2 → 5.2.0 | Pas de correctif indiqué |
Références
- lists.apache.org lists.apache.org
- www.openwall.com www.openwall.com
Chronologie
- Publiée
- Dernière modification