Aller au contenu
Non notée

CVE-2023-33246 Apache RocketMQ Command Execution Vulnerability

Exploitation active constatée

· catalogue CISA KEV
Action attendue Apply mitigations per vendor instructions or discontinue use of the product if mitigations are unavailable.
Campagnes de rançongiciel Non constatée à ce jour
Faiblesse CWE-94

Description

For RocketMQ versions 5.1.0 and below, under certain conditions, there is a risk of remote command execution.  Several components of RocketMQ, including NameServer, Broker, and Controller, are leaked on the extranet and lack permission verification, an attacker can exploit this vulnerability by using the update configuration function to execute commands as the system users that RocketMQ is running as. Additionally, an attacker can achieve the same effect by forging the RocketMQ protocol content.  To prevent these attacks, users are recommended to upgrade to version 5.1.1 or above for using RocketMQ 5.x or 4.9.6 or above for using RocketMQ 4.x .

Produits et versions touchés

Produit Versions touchées Corrigé en
Apache RocketMQ 5.1 premières → 5.1.0 Pas de correctif indiqué
Les 3 CVE de Apache RocketMQ →
Suivre cette CVE