Aller au contenu
6.5 Moyenne

CVE-2024-12421 The The Coupon Affiliates – Affiliate Plugin for WooCommerce plugin for WordPress is vulnerable to arbitrary shortcode…

Description

The The Coupon Affiliates – Affiliate Plugin for WooCommerce plugin for WordPress is vulnerable to arbitrary shortcode execution in all versions up to, and including, 5.16.7.1. This is due to the software allowing users to execute an action that does not properly validate a value before running do_shortcode. This makes it possible for unauthenticated attackers to execute arbitrary shortcodes. This functionality is also vulnerable to Reflected Cross-Site Scripting. The Cross-Site Scripting was patched in version 5.16.7.1, while the arbitrary shortcode execution was patched in 5.16.7.2.

Produits et versions touchés

Produit Versions touchées Corrigé en
Coupon Affiliates – Affiliate Plugin for WooCommerce 5.16 premières → 5.16.7.1 Pas de correctif indiqué
Les 4 CVE de Coupon Affiliates – Affiliate Plugin for WooCommerce →
Suivre cette CVE