Skip to content
6.5 Medium

CVE-2024-12421 The The Coupon Affiliates – Affiliate Plugin for WooCommerce plugin for WordPress is vulnerable to arbitrary shortcode…

Description

The The Coupon Affiliates – Affiliate Plugin for WooCommerce plugin for WordPress is vulnerable to arbitrary shortcode execution in all versions up to, and including, 5.16.7.1. This is due to the software allowing users to execute an action that does not properly validate a value before running do_shortcode. This makes it possible for unauthenticated attackers to execute arbitrary shortcodes. This functionality is also vulnerable to Reflected Cross-Site Scripting. The Cross-Site Scripting was patched in version 5.16.7.1, while the arbitrary shortcode execution was patched in 5.16.7.2.

Affected products and versions

Product Affected versions Fixed in
Coupon Affiliates – Affiliate Plugin for WooCommerce 5.16 earliest → 5.16.7.1 No fix stated
The 4 CVEs of Coupon Affiliates – Affiliate Plugin for WooCommerce →
Track this CVE