Aller au contenu
9.8 Critique

CVE-2024-10124 The Vayu Blocks – Gutenberg Blocks for WordPress & WooCommerce plugin for WordPress is vulnerable to unauthorized…

Description

The Vayu Blocks – Gutenberg Blocks for WordPress & WooCommerce plugin for WordPress is vulnerable to unauthorized arbitrary plugin installation and activation due to a missing capability check on the tp_install() function in all versions up to, and including, 1.1.1. This makes it possible for unauthenticated attackers to install and activate arbitrary plugins which can be leveraged to achieve remote code execution if another vulnerable plugin is installed and activated. This vulnerability was partially patched in version 1.1.1.

Produits et versions touchés

Produit Versions touchées Corrigé en
Vayu Blocks – Gutenberg Blocks for WordPress & WooCommerce 1.1 premières → 1.1.1 Pas de correctif indiqué
Vayu Blocks – Website Builder for the Block Editor 1.1 premières → 1.1.1 Pas de correctif indiqué
Les 4 CVE de Vayu Blocks – Gutenberg Blocks for WordPress & WooCommerce →
Suivre cette CVE