9.8
Critical
CVE-2024-10124 The Vayu Blocks – Gutenberg Blocks for WordPress & WooCommerce plugin for WordPress is vulnerable to unauthorized…
Description
The Vayu Blocks – Gutenberg Blocks for WordPress & WooCommerce plugin for WordPress is vulnerable to unauthorized arbitrary plugin installation and activation due to a missing capability check on the tp_install() function in all versions up to, and including, 1.1.1. This makes it possible for unauthenticated attackers to install and activate arbitrary plugins which can be leveraged to achieve remote code execution if another vulnerable plugin is installed and activated. This vulnerability was partially patched in version 1.1.1.
Affected products and versions
| Product | Affected versions | Fixed in |
|---|---|---|
| Vayu Blocks – Gutenberg Blocks for WordPress & WooCommerce 1.1 | earliest → 1.1.1 | No fix stated |
| Vayu Blocks – Website Builder for the Block Editor 1.1 | earliest → 1.1.1 | No fix stated |
Other CVEs of Vayu Blocks – Gutenberg Blocks for WordPress & WooCommerce
The 4 CVEs of Vayu Blocks – Gutenberg Blocks for WordPress & WooCommerce →
CVE-2025-4420
The Vayu Blocks – Gutenberg Blocks for WordPress & WooCommerce plugin for WordPress is vulnerable to Stored Cross-Site…
6.4
Medium
CVE-2025-2568
The Vayu Blocks – Gutenberg Blocks for WordPress & WooCommerce plugin for WordPress is vulnerable to unauthorized access…
5.3
Medium
CVE-2025-22644
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in ThemeHunk Vayu…
6.5
Medium