Aller au contenu
Non notée

CVE-2022-37022 Apache Geode versions up to 1.12.2 and 1.13.2 are vulnerable to a deserialization of untrusted data flaw when using…

Description

Apache Geode versions up to 1.12.2 and 1.13.2 are vulnerable to a deserialization of untrusted data flaw when using JMX over RMI on Java 11. Any user wishing to protect against deserialization attacks involving JMX or RMI should upgrade to Apache Geode 1.15. Use of 1.15 on Java 11 will automatically protect JMX over RMI against deserialization attacks. This should have no impact on performance since it only affects JMX/RMI which Gfsh uses to communicate with the JMX Manager which is hosted on a Locator.

Produits et versions touchés

Produit Versions touchées Corrigé en
Apache Geode 1.12 premières → 1.12.2 Pas de correctif indiqué

Références

Chronologie

  1. Publiée
  2. Dernière modification
Les 18 CVE de Apache Geode →
Suivre cette CVE