Aller au contenu
7.5 Élevée

CVE-2022-34169 The Apache Xalan Java XSLT library is vulnerable to an integer truncation issue when processing malicious XSLT…

Description

The Apache Xalan Java XSLT library is vulnerable to an integer truncation issue when processing malicious XSLT stylesheets. This can be used to corrupt Java class files generated by the internal XSLTC compiler and execute arbitrary Java bytecode. Users are recommended to update to version 2.7.3 or later. Note: Java runtimes (such as OpenJDK) include repackaged copies of Xalan.

Produits et versions touchés

Produit Versions touchées Corrigé en
Apache Xalan-J 2.7 premières → 2.7.2 Pas de correctif indiqué

Références

Chronologie

  1. Publiée
  2. Dernière modification
Suivre cette CVE