Skip to content
7.5 High

CVE-2022-34169 The Apache Xalan Java XSLT library is vulnerable to an integer truncation issue when processing malicious XSLT…

Description

The Apache Xalan Java XSLT library is vulnerable to an integer truncation issue when processing malicious XSLT stylesheets. This can be used to corrupt Java class files generated by the internal XSLTC compiler and execute arbitrary Java bytecode. Users are recommended to update to version 2.7.3 or later. Note: Java runtimes (such as OpenJDK) include repackaged copies of Xalan.

Affected products and versions

Product Affected versions Fixed in
Apache Xalan-J 2.7 earliest → 2.7.2 No fix stated

References

Timeline

  1. Published
  2. Last modified
Track this CVE