Skip to content
Not rated

CVE-2026-86247 Race condition within a thread vulnerability in Apache Tomcat Native allowed client certificate verification…

Description

Race condition within a thread vulnerability in Apache Tomcat Native allowed client certificate verification requirements to be down-graded for some configurations. This issue affects Apache Tomcat Native: from 2.0.0 through 2.0.15, from 1.3.0 through 1.3.8. Unsupported versions may also be affected. Users are recommended to upgrade to version 2.0.16 or 1.3.9, which fixes the issue.

Affected products and versions

Product Affected versions Fixed in
Apache Tomcat Native 2.0 2.0.0 → 2.0.15 No fix stated
Apache Tomcat Native 1.3 1.3.0 → 1.3.8 No fix stated
The 8 CVEs of Apache Tomcat Native →
Track this CVE