Skip to content
Not rated

CVE-2026-86243 Buffer over-read vulnerability in Apache Tomcat Native during the TLS handshake permits a malicious user to trigger a…

Description

Buffer over-read vulnerability in Apache Tomcat Native during the TLS handshake permits a malicious user to trigger a DoS via a JVM crash. This issue affects Apache Tomcat Native: from 2.0.0 through 2.0.15, from 1.3.0 through 1.3.8. Earlier, unsupported versions may also be affected. Users are recommended to upgrade to version 1.3.9 or 2.0.16, which fix the issue.

Affected products and versions

Product Affected versions Fixed in
Apache Tomcat Native 2.0 2.0.0 → 2.0.15 No fix stated
Apache Tomcat Native 1.3 1.3.0 → 1.3.8 No fix stated

References

Timeline

  1. Published
  2. Last modified
The 8 CVEs of Apache Tomcat Native →
Track this CVE