Skip to content
Not rated

CVE-2026-73634 Uncontrolled resource consumption vulnerability in Apache Struts

Description

Uncontrolled resource consumption vulnerability in Apache Struts. An application that exposes an endpoint collecting Content Security Policy violation reports reads the submitted report into memory without bounding how much it will accept, so a single request can exhaust the heap and deny service to other users. Such endpoints are ordinarily reachable without authentication. The core distribution maps no such endpoint by default; applications that do not collect violation reports are not affected. This issue affects Apache Struts: from 6.0.0 through 6.10.0, from 7.0.0 through 7.2.1. Users are recommended to upgrade to version 6.11.0 or 7.3.0, which fixes the issue.

Affected products and versions

Product Affected versions Fixed in
Apache Struts 7.0 7.0.0 → 7.2.1 No fix stated
Apache Struts 6.0 6.0.0 → 6.10.0 No fix stated

References

Timeline

  1. Published
  2. Last modified
The 33 CVEs of Apache Struts →
Track this CVE